主にステマブログ

ガチャメーカーについてのブログです。つれづれなるままにひぐらし

rails4でbootstrap3つかう

 

先日、lessのbootstrap("twitter-bootstrap-rails")をいれたんだけど、

バージョンが2.3と古かった。

Bootstrap

をみると、そろそろサポートされなくなるようなので、今から使うのはちょっと・・

と思い、sass版を使うことにした。sass版は3.0に対応しているみたい。

 

最近環境構築ばっかやっている気がするけど

1.GemFIleを編集

・追加

gem 'bootstrap-sass', '~> 3.0.3.0'

・以下コメントイン

# gem 'therubyracer', platforms: :ruby

あと、sass-railsは、3.2以上が必要。(手持ちのrails4環境は、4.0になってた)

で、bundle install

 

2.stylesheetにインポート

app/assets/stylesheetsに、bootstrap_and_override.css.scssを追加して、

以下の設定を書く。

(ファイル名はなんでもいいと思うが、bootstrap.cssなどとすると既存とかぶる)

@import "bootstrap";
@import "bootstrap/theme";

 

3.javascript

application.jsに、以下追加

// Loads all Bootstrap javascripts
//= require bootstrap

 

lessと違い、generator等がないので、自分で適当にコード入れて試してみた。

iconが、glyphiconになったりしてるんだねふーん

参考にしたサイト

twbs/bootstrap-sass · GitHub

 

owari